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Instructions for LTspice Laboratory Exercise 

LC Filter 
We consider a power supply that has a resistive load. We want to filter out the high frequency components from 
the power supply, so we construct an L-C low-pass filter (LPF) and place the resistor in parallel with the filter 
capacitor. We want to examine the properties of this circuit. The load resistor has a value of 5 Ω. The inductor in 
the LPF has a value of 500 𝜇𝜇𝜇𝜇 and the capacitor has a value of 1000 𝜇𝜇𝜇𝜇. 

 

 

 

 

 

1. Open a new schematic:  File->New Schematic (Ctrl-N) 
2. Add components 

a. Voltage source:  Edit->Component, F2, or AND gate icon from menu-> 
i. Ensure top directory is ..\LTspiceXVII\lib\sym 

ii. Select voltage 
iii. Place and escape to exit 

b. Inductor:  Edit->Inductor or select from menu, place, Ctrl-R to rotate, escape to exit 
c. Capacitor:  Edit->Capacitor or select from menu, place, escape to exit 
d. Resistor:  Edit->Resistor or select from menu, place, escape to exit 
e. Ground:  Edit-> GND or select from menu, place, escape to exit 

3. Connect components:  Edit->Draw Wire, F3, or select Line icon from menu 
a. Click on GND, draw to V- and click 
b. Click on V+, draw in right angles to LHS of inductor, clicking on the corners and inductor 
c. Click on RHS of inductor, draw in right angles to top of resistor, clicking on corner of resistor 
d. Click on bottom of resistor, draw in right angles to bottom of line between GND and V-, clicking 

on corners and termination line 
e. Click on line from inductor to resistor and click on top of capacitor 
f. Click on line from resistor to ground and click on bottom of capacitor 
g. Escape to exit 

4. Set the values of the components 
a. Inductor:  Right click on the inductor, enter 500u in inductance box, OK 
b. Capacitor:  Right click on the capacitor, enter 1000u in capacitance box, OK 
c. Resistor:  Right click on the resistor, enter 5 in resistance box, OK 
d. Voltage source:  Right click on the voltage source, go to Advanced, enter 0 in DC value box, enter 

1 in AC Amplitude box, OK 

+
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Frequency Response 
We first find the frequency response of this circuit.  The resonant frequency of the filter components is 

𝑓𝑓 =
1

2𝜋𝜋
1

√𝐿𝐿1 ⋅ 𝐶𝐶1
=

1
2𝜋𝜋

106

√5 ⋅ 105
= 225 𝐻𝐻𝐻𝐻 

so we Simulate->Edit Simulation Command->AC Analysis and set up a Decade sweep with 1000 points per 
decade, starting at 10 Hz and ending at 10k Hz.  This translates into a command 
.ac dec 1000 10 10k, which will appear on the LTspice schematic. 

1. Setup the analysis 
a. Edit->Spice Analysis or Simulate->Edit Simulation Command  ->AC Analysis 

i. Type of sweep:  Decade 
ii. Number of points per decade:  1000 

iii. Start frequency:  10 
iv. Stop frequency:  10k 
v. OK 

b. Or Edit->Spice Analysis->.ac dec 1000 10 10k, OK 
c. Click on schematic to place command 

2. Save schematic as lcFilterFreq. 
3. Run simulation:  Select runner icon, or Simulate->Run 

(A netlist is created in lcFilterFreq.net.  This contains the SPICE commands 
* C:\files\ltSpiceFiles\examples\2017\lcFilterFreq.asc 
V1 N001 0 0 AC 1 
L1 N001 N002 500µ 
C1 N002 0 1000µ 
R1 N002 0 5 
.ac dec 1000 10 10k 
.backanno 
.end 
that tell SPICE about your schematic.  Note that there are three voltage nodes, N001, N002, and 0 
(GND), the four devices V1, L1, C1, and R1, the command for AC analysis (.ac directive), and an LTspice 
command, backanno, that allows you to select voltages and currents for graphical output.  If I use the 
Label Net command (F4), I can attach a label to, for example, the output and call it Vout.  Unlabeled, 
LTspice identified this as N002.  Labeled, the netlist now uses your defined label.  Labeling can make the 
drawing more readable and also makes selecting values for plotting easier.) 
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Figure 1:  lcFilterFreq.asc 

4. Plots: 
a. Voltage:  Hover over a wire with the cursor.  If the wire is not at ground potential, a voltage 

probe will appear and the voltage node it is over will appear in the lower left corner of the 
LTspice window.  The voltage on any node can be plotted by clicking on a wire connected to the 
node.  A voltage difference can be plotted by first depressing the mouse key on one node, then 
sliding the probe over to a second node while the key is still depressed, and then releasing the 
key. 

b. Current:  Hover over a device with the cursor.  A current probe will appear and the device it is 
over will appear in the lower left corner of the LTspice window.  The current through any device 
can be plotted by clicking on that device. 

c. Power:  Depress the Alt key and hover over a device that can dissipate power (resistor or 
semiconductor).  A thermometer will appear.  Click and the power dissipated in that device will 
be plotted.  (The thermometer icon to measure power only works for some types of LTspice 
simulations.  It does not appear to work for .ac simulations.  To plot the power in these cases, 
one can add an expression for the power as described in subsection d., below.) 

d. Functions of basic plots:  Sometimes one wants to plot an arithmetic function of node voltages 
and/or branch currents.  To do this, make the plot window (.raw) the active window and then 
add a trace by opening another window using either Plot Settings->Add trace or Ctrl-A, and then 
entering the mathematical expression in the “Expression(s) to add” box.  For example, another 
way to add the voltage across the inductor, enter V(n001) – V(n002), OK, or to calculate the 
power through the damping resistor R1 would be to enter (V(n00x)-V(n00y))*I(R1), OK, where 
n00x is the node on one side of R1 and n00y is the node on the other side. 

e. Cursors:  The waveform plotting routine has two cursors.  One can activate the cursor by left 
clicking on the label of a plot.  A cursor box will appear with the horizontal and vertical 
coordinates of the waveform point under the cursor.  Alternatively, one can right click on the 
desired plot label and select the cursors from the Attached Cursor box at the top of the 
Expression Editor.  The choices are none, 1st, 2nd, or 1st & 2nd. 

f. One can change parameters of the plot by hovering the cursor along an axis outside of a plot 
until a ruler icon appears and then right clicking.  That can allow you to change the axis values 
and, if a vertical axis, delete a family of plots, such as amplitude or phase for a Bode plot. 
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5. Run the simulation and then place a voltage probe on the resistor and view the amplitude and phase of 
the result. The peak of the response is close to 225 Hz (it is a little lower because of the resistor) 
 

6. The phase of the response changes from 0° to −180° as the frequency goes through the resonance. 
a. Record the frequency at which the response is a maximum and record the amplitude, in dB, at that 
frequency 
 
_____________________________ Hz  _______________________________ dB 

7. Record the frequencies and amplitudes at which the phases are −45°, −90°, and −135°, respectively 
 
-45O ______________________Hz  __________________dB 
 
-90O ______________________Hz  __________________dB 
 
-135O ______________________Hz  __________________dB 
 
This shows the maximum amplitude occurs at approximately -90O and that the amplitudes are down 
approximately 3dB 45 degrees on either side of 90 degrees. 

8. You can document your work for publication using Tools->Write image to .emf file.  First select the window 
you want to convert to .emf and then use the Tools->Write image to .emf file command.  This works for 
both the schematic and the data plots. 

Step Response 
We now find the time response of this signal to a step impulse. 

1. Delete (Edit->Delete, F5, or scissors icon) the .ac directive from the schematic 
2. Right click on the voltage source, already in Advanced, enter 1 in DC value box, and either enter 0 in AC 

Amplitude box or delete the 1 from the box to leave it blank, OK. 
3. Edit->Spice Analysis or Simulate->Edit Simulation Command  ->  Transient 

a. Stop time:  50m 
b. Time to start saving data:  0 
c. Select “Start external DC supply voltages at 0V” 
d. OK 

4. Or enter Transient command:  .tran 0 50m 0 startup, then OK 
5. Click to enter command on schematic 
6. Save file as lcFilterStep 
7. Run simulation:  Select runner icon, or Simulate->Run 
8. Place a voltage probe on R1 
9. Observe the ringing of the voltage on the resistor 
10. Sketch the output voltage waveform over 50ms. Estimate and record the time between the initial peaks. 

To what frequency does this correspond? 
 
 
 
 
 



Page 5 of 20 

 
 
 
 
 
 
 

 

11. Record the ratio of the amplitude of the second peak, with respect to the final value of the voltage, 
𝑣𝑣(∞), to the amplitude of the first peak, with respect to 𝑣𝑣(∞).  A single pole damped circuit decays 
exponentially.  If the excitation were an impulse, the oscillation would be about the origin.  If the 
excitation is a step, the voltage oscillates about the value of the step.  If there is damping in the circuit, 
after a sufficiently long time the voltage damps to the value of the input step.  Using the ratio of these 
peaks and the time difference between the peaks, calculate a damping time 𝜏𝜏 using the formula 𝑒𝑒−𝑡𝑡/𝜏𝜏 to 
fit the data. 

𝑣𝑣(𝑡𝑡 + 𝑇𝑇) − 𝑣𝑣(∞)
𝑣𝑣(𝑡𝑡) − 𝑣𝑣(∞)

=
𝑉𝑉𝑜𝑜𝑒𝑒

− 𝑡𝑡+𝑇𝑇𝜏𝜏 sin𝜔𝜔(𝑡𝑡 + 𝑇𝑇)

𝑉𝑉𝑜𝑜𝑒𝑒
− 𝑡𝑡𝜏𝜏 sin𝜔𝜔(𝑡𝑡)

= 𝑒𝑒− 𝑇𝑇𝜏𝜏  

Since the value of sin𝜔𝜔𝜔𝜔 is the same at the two measurement times, solving for τ we get 

𝜏𝜏 = −
𝑇𝑇

𝑙𝑙𝑙𝑙 𝑣𝑣(𝑡𝑡 + 𝑇𝑇)
𝑣𝑣(𝑡𝑡)

 

Ratio:  ____________________________________ 

 

Damping time 𝜏𝜏:  ______________________________________ 
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Figure 2:  lcFilterStep.asc 

 

 

 

 

Damped Filter 
In order to damp the frequency response of our L-C filter, we add a damping resistor to the circuit.  We will use 
LTspice to see what value of damping resistor to add in parallel with our load resistor. 

 

 

 

 

 

 

 

Parametric Analysis 
In order to efficiently select the filter we will use the LTspice .STEP function that allows us to perform a 
parametric analysis.  This introductory section gives an overview of how to perform such an analysis on the 
resistor in a damped filter.  You will be stepped through the instructions later in this section of the laboratory 
exercise. 

Vary the parametric component by right clicking on it. Under Component Properties (Resistor, capacitor, or 
Inductor) enter {R}, or {C}, or {L} in the Resistance, Capacitance, or Inductance box. Note that the braces {} around 
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the parameter name are required.  This tells LTspice the component value is a global parameter. Close the 
component box by selecting the OK button. 

Add a spice directive to the circuit in one of three ways. Depress the s key, use the .op command at the right hand 
side of the menu, or select the SPICE Directive from the Edit pull down menu. All of these ways opens a dialog box 
Edit Text on the Schematic. Ensure highlight of the SPICE Directive radio button. Type the needed command (see 
the example below) then left click the directive onto the circuit diagram. 

For example, the command .step dec param R 0.01 1.0 4, steps the parameter R logarithmically from 0.01 ohms 
to 1.0 ohms in four steps per decade when the Run command is chosen. Display the plots for all of the steps by 
then selecting the voltage or current of interest and displaying the plot. To select only specific plots, choose Select 
Steps to display the traces of interest from the Plot Settings drop down menu. 

In order to step through the parameter in linear increments, we modify the command to .step param R 0.05 
0.15 0.02, which starts with R at 0.05 ohms, and steps in increments of 0.02 ohms to 0.15 ohms. 

To return to the original value we can either delete the .step command and replace it with a command used to 
set R .param R 0.1, or remove the command altogether, to return to the damping resistor properties and replace 
{R} with the desired value. 
 
This concludes the introduction. 
 

Parametric Analysis 
1. Either work with the existing schematic, or load a previous schematic, File->Open lpFilterFreq.asc 
2. Add an additional shunt resistor for extra damping:  Edit->Resistor or select from menu, place, escape to 

exit 
3. Connect resistor to existing circuit using Edit->Draw Wire, F3, or select Line icon from menu.  Escape 

when finished. 
Set this second resistor as a parameterized object:  Right click on the resistor and enter the resistance as 
{Rdamp} to tell LTspice that this resistance will be treated as a parameterized value. 
Hint: You need a starting value for the parameterized damping resistor.  In an 𝐿𝐿 − 𝐶𝐶 circuit, the only 
quantity you can create with the units of impedance is 𝑅𝑅 = �𝐿𝐿1/𝐶𝐶1.  Although this may not be the value 
of the “best” damping resistor, it should be close to that value, so 𝑅𝑅 = �𝐿𝐿1/𝐶𝐶1 is a good value to include 
in your parameterization. 

4. Delete the .tran directive. Add the SPICE command to tell LTspice the parameters of interest:  Edit-
>SPICE Directive 
.step dec param Rdamp 0.01 10 4 
This tells LTspice that Rdamp will be a parameter, where the value of R will be varied logarithmically 
from 0.01 Ω to 10 Ω with four steps per decade. 

5. Set up an AC analysis from 20 Hz to 2 kHz: 
a. Edit->Spice Analysis or Simulate->Edit Simulation Command  ->AC Analysis 

i. Type of sweep:  Decade 
ii. Number of points per decade:  1000 

iii. Start frequency:  20 
iv. Stop frequency:  2k 
v. OK 
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b. Or Edit->Spice Analysis->.ac dec 1000 20 2k, OK 
c. Click on schematic to place command 
d. Ensure voltage source is prepared for the AC analysis.  Right click on the voltage source, go to 

Advanced, enter 0 in DC value box, enter 1 in AC Amplitude box, OK 
6. Save file as lcFilterDampFreq 
7. Run simulation:  Select runner icon, or Simulate->Run 
8. Plot Settings->Select Steps allows you to select which of the parameterization values of R you wish to 

plot 
9. Replace the .step command with a command that will vary the parameter linearly from 0.5 Ω to 2 Ω in 

steps of 0.1 Ω.  Right click on the .step command to bring up the .step Statement Editor: 
a. Either use the prompts 

i. Name of parameter to sweep:  R 
ii. Nature of sweep:  Linear 

iii. Start value:  0.5 
iv. Stop value:  2.0 
v. Increment:  0.1 

b. Or enter .step param R 0.5 2.0 0.1 in the bottom box 
c. OK 

10. Run simulation:  Select runner icon, or Simulate->Run 
11. Choose the desired resistor value (when the output voltage is essentially critically damped).  Note that 

this “desired” resistor value is somewhat subjective.  There are tradeoffs between such circuit 
parameters as rise time, overshoot, etc., that are determined by the choice of the resistor value.  You 
should briefly explain why you chose your desired resistor value. 

12. Replace the Resistance value {R} with the desired value and record this value 
 
 
_______________________________ 
 
 
 

13. Delete the .step Spice command from the circuit. Run an AC simulation to verify this resistor value has 
the desired response and sketch the confirmation 
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Figure 3:  lcFilterDampFreq.asc 

 
 
 
 
 
 
 
 
 

 

Transient Analysis 
Leaving the circuit alone, modify the excitation to obtain a step response 

1. Right click on the voltage source to set the source to a DC value 
a. DC value:  1 
b. AC Amplitude:  0 
c. OK 

2. Right click on the .ac command to open the Edit Simulation Command box and 
a. Either 

i. Select Transient tab 
ii. Stop time:  10m 

iii. Time to start saving data:  0 
iv. Select Start external DC supply voltages at 0V 

b. Or in lower box enter 
i. .tran 0 10m 0 startup 

c. OK 
3. Save file as lcFilterDampStep.asc 
4. Run simulation:  Select runner icon, or Simulate->Run 
5. Sketch the circuit output voltage. Sketch and record the power dissipated in the resistor (see sections 

4.c and 4.d in the discussion of Frequency Response  - Plots above). 
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a. Output Voltage 
 
 
 
 
 
 
 
 

 

b. R2 Dissipated Power 

 

 

 

 

Figure 4: lcFilterDampStep.asc 

Praeg Filter 
The circuit we just designed has the desired frequency response, but at the expense of dissipating most of the 
power in the damping resistor.  If we mainly want to drive a DC load, we can insert a capacitor in series with our 
damping resistor to block the DC current and reduce the power dissipated in this resistor. 
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Parametric Analysis 
1. Load the lpFilterDampFreq.asc:  File->Open lpFilterDampFreq.asc 
2. If not already done, set up an AC analysis from 20 Hz to 2 kHz: 

a. Edit->Spice Analysis or Simulate->Edit Simulation Command  ->AC Analysis 
i. Type of sweep:  Decade 

ii. Number of points per decade:  1000 
iii. Start frequency:  20 
iv. Stop frequency:  2k 
v. OK 

b. Or Edit->Spice Analysis->.ac dec 1000 20 2k, OK 
c. Click on schematic to place command 

3. Delete the .step statement:  F5, select, escape 
4. Modify the damping resistor (R2) parameter to include the desired resistance:  Right click on resistor, 

replace {R} with desired value, OK. 
5. Modify the circuit layout, if necessary, to allow a capacitor in series with R2.  F7 is Move, F8 is Drag.  

Drag is similar to move, but wires rubber band along with selected objects. 
6. Delete the wire connecting R2 to ground:  F5, select, escape 
7. Add a capacitor:  Edit->Capacitor or select from menu, place, escape to exit 
8. Connect the capacitor to R2 and GND using Edit->Draw Wire (F3), escape to exit 
9. Set C2 to be parameterized 

a. Right click on C and set Capacitance to {C} 
b. Add the SPICE command to tell LTspice the parameters of interest:  Edit->SPICE Directive 

.step param C 3000u 7000u 1000u 
OK then place 
to step through five values of the capacitance. 

10. Save the file as praegFreq.asc:  File->Save As praegFreq.asc 
11. Run simulation:  Select runner icon, or Simulate->Run 
12. Select and record an acceptable capacitor value for this load 

Hint: From class notes 𝐶𝐶2 = 5 ∗ 𝐶𝐶1 

 

 
____________________________ µF 

 

AC Analysis 
Perform an AC analysis to obtain the frequency response .ac dec 1000 20Hz 2kHz 

13. Record the frequency at the peak of the response and the relative gain (in dB) at this frequency 
 

 



Page 12 of 20 

 

__________________________________ Hz,  ____________________________________dB 

14. Compare these results with those from the damped filter. 
 
 
 
 
 
  

 

 

 

 

Figure 5: praegFreq.asc 

Transient Analysis 
Leaving the circuit alone, modify the excitation to obtain a step response 

1. Right click on the voltage source to set the source to a DC value 
a. DC value:  1 
b. AC Amplitude:  0 
c. OK 

2. Right click on the .ac command to open the Edit Simulation Command box and 
a. Either 

i. Stop time:  10m 
ii. Time to start saving data:  0 

iii. Select Start external DC supply voltages at 0V 
b. Or in lower box enter 

i. .tran 0 10m 0 startup 
c. OK 

3. Save file as praegStep.asc 
4. Run simulation:  Select runner icon, or Simulate->Run 
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5. Select desired capacitance and replace the parameter C with that value.  Delete the .step statement. 
6. Sketch the output voltage versus time 

 

 

 

 

 

 

 

Sketch the power dissipated in the damping resistor (V(n002)− V(n001)) ∗ I(R2) over 50ms. Note 
that the steady state resistor power is zero 

 

 

 

 

Figure 6:  praegStep.asc 

 

 

 

 

Buck Regulator 
Now that we have the desired load and filter, we will build a buck regulator power supply and look at its step 
responses. 
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Initial Response 
1. Load praegFreq.asc:  File->Open praegFreq.asc 
2. Ensure that the parameters for R2 and C2 have been replaced by the desired components and delete 

(F5) any unneeded step statements 
3. Drag (F8 and select) the filter components to the right of the schematic to make room for other 

components.  Left click when the components are in the desired location, then escape. 
4. Add components: 

a. IGBT: 
i. Edit->Component, F2, or AND gate icon from menu 

ii. In top line, pull down menu and select custom directory (ltSpiceFiles\sym) 
iii. Select irgp4063dpbf, click OK 
iv. Rotate the device (Ctrl-R) until the gate faces down 
v. Place and escape to exit 

b. Voltage source: 
i. Edit->Component, F2, or AND gate icon from menu 

ii. Ensure top directory is ..\LTspiceXVII\lib\sym 
iii. Select voltage, OK, rotate (Ctrl-R) until positive terminal faces left 
iv. Place and escape to exit 

c. Diode: 
i. Edit->Component, F2, or AND gate icon from menu 

ii. Ensure top directory is ..\LTspiceXVII\lib\sym 
iii. Select diode, OK, rotate (Ctrl-R) until the cathode faces up 
iv. Place and escape to exit 

d. Resistor:  Edit->Resistor or select from menu, rotate (Ctrl-R) until it is horizontal, place, escape 
to exit 

5. Modify schematic 
a. Delete (F5) trace between V1 and L1, escape to exit 
b. Move (F7) components to look like figure. 
c. Draw Wire (F3) to connect the devices as in the figure. 

6. Set the remaining component values 
a. Set V1 to 100 VDC:  Right click on V1, DC value 100, AC Amplitude 0, OK 
b. Set R3 to 10 Ω:  Right click on R3, Resistance 10, OK 
c. Set D1 to carry at least 20 A with a breakdown voltage greater than 250 VDC (conservative 

choices) 
i. Right click on D1 

ii. Pick New Diode 
iii. Select RF1501NS3S 



Page 15 of 20 

iv. OK 
d. Set V2 to be the gate drive, a pulse train to give a pulse-width modulated control of the IGBT.  A 

gate value of -5 V keeps the IGBT off and a gate value of 20 V turns the IGBT on.  We will start 
the pulse train immediately (Tdelay = 0), set the pulse period for 100 𝜇𝜇s, set its duty cycle to 
25% (Ton = Tperiod/4), and set some reasonable rise and fall times.  Based on our filter response 
we expect the filter to settle out within a few ms, we set the number of cycles to 500 for a 50 ms 
excitation time.  We will see the command 
PULSE(-5 20 0 2u 2u 25u 100u 500) by V2 

i. Right click on V2 
ii. Advanced 

iii. Select PULSE function 
iv. Vinitial = -5; Von = 20; Tdelay = 0; Trise = 2u; Tfall = 2u; Ton = 25u; Tperiod = 100u; 

Ncycles = 500 
v. OK 

7. Set up a transient simulation: 
a. Simulate->Edit Simulation Cmd 

i. Transient 
ii. Stop time: 50m (this is Ncycles⋅Tperiod) 

iii. Time to start saving data:  0 
iv. OK 

b. This gives a simulation command of .tran 0 50m 0 
8. Save file File->Save As buckInitial.asc 
9. Run simulation:  Select runner icon, or Simulate->Run 
10. Sketch 𝑉𝑉(𝑅𝑅1), Io 𝐼𝐼(𝑅𝑅1), on one plot 

 

 

 

 

 

 

 

 

 

 

11. Sketch 𝐼𝐼(𝐶𝐶1), the current in the main Praeg capacitor C1 over 50ms and then over two cycles under 
steady-state conditions 
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12. On one plot sketch two cycles of the filter inductor L1 voltage (V(n002)-V(n003)), and current (IL1) under 
steady state conditions  
 

 

 

 

 

 

13. On one plot sketch two cycles of the free-wheeling diode VD1, and ID1 under steady state conditions 
 

 

 

 

 

 

 

14. On one plot sketch two cycles of the drain-to-source IGBT voltage (V(n001)-V(n002)) and current (-I(V1)) 
under steady state conditions 
 

 

 

 

 

 

 

 

 

15. On one plot sketch two cycles of the input voltage (V1) and current (-I(V1)) under steady state 
conditions 
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Figure 7:  buckInitial.asc 

 

Figure 8:  buckNet.asc 
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Buck Regulator, Modified (Step Change in Operating Point) 
We will now modify the circuit slightly to see how it responds to a step change in its operational point.  

 

 

 

 

 

 

 

 

We do this by adding a second voltage source in series with V2 and setting the pulses of each so that: 

• They are each have different duty cycles 
• They are set to zero volts while the other source is pulsing 

 

1. Load buckInitial.asc:  File->Open buckInitial.asc 
2. Drag (F8, select, and drag) the diode and passive components, if necessary, to get extra space.  Select to 

place and escape to exit. 
3. Delete (F5) the wire connecting V2- to the IGBT emitter, escape to exit 
4. Add a voltage source: 

a. Edit->Component, F2, or AND gate icon from menu 
b. Ensure top directory is ..\LTspiceXVII\lib\sym 
c. Select voltage, OK, rotate (Ctrl-R) until positive terminal faces left 
d. Place and escape to exit 

5. Wire the new voltage source, V3, to be in series with V2. 
a. Draw Wire (F3) 
b. Place at each destination 
c. Escape to exit 

6. Set PULSE parameters of V2.  We will only pulse this for 200 cycles. 
a. Vinitial = -5; Von = 20; Tdelay = 0; Trise = 2u; Tfall = 2u; Ton = 25u; Tperiod = 100u; Ncycles = 200 

7. Set PULSE parameters of V3.  We will hold this off for the first 20 ms while V2 is pulsing, then turn it on 
at a different duty cycle for another 20 ms.  Since V2 will be at -5 V when it is not pulsing, V2 needs to 
pulse between 0 V and 25 V. 

a. Right click on V3 
b. Advanced 
c. Select PULSE function 
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d. Vinitial = 0; Von = 25; Tdelay = 20m; Trise = 2u; Tfall = 2u; Ton = 30u; Tperiod = 100u; Ncycles = 
200 

e. OK 
8. Modify the simulation command to calculate for 40 ms 

a. Simulate->Edit Simulation Cmd 
i. Transient 

ii. Stop time: 40m (this is 2⋅Ncycles⋅Tperiod) 
iii. Time to start saving data:  0 
iv. OK 

b. This gives a simulation command of .tran 0 40m 0 
9. Save file File->Save As buckSteadyState.asc 
10. Run simulation:  Select runner icon, or Simulate->Run 
11. Examine the behavior, especially at t=20 ms, when the supply changes its operating point. Sketch the 

change in output voltage during the transition. 
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Figure 9:  buckSteadyState.asc 
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